09 Multilayer Forum

Started by Mindless, July 21, 2012, 09:27:17 AM

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.

rickandmary

not sure that is going to solve his problem denede and think he needs user functions

denede

#31
Quote from: autotron on September 25, 2013, 11:54:05 PM
Quote from: denede on September 25, 2013, 09:41:37 AM
just need to delete the line from the file where require_once user_functions.

Now why would you delete the require once???

because of the error he gets on forum manager?
hmm.. but i don't have any problem. did the same for me and it works.

autotron

Quote from: denede on September 25, 2013, 09:41:37 AM
just need to delete the line from the file where require_once user_functions.

Now why would you delete the require once???

denede

just need to delete the line from the file where require_once user_functions.

rickandmary

on your lang file, line above line 24 'index_news' => 'Add/Delete News'  needs to be 'index_news' => 'Add/Delete News', if you can please post your other file?

MaD42

#27
I have 3 errors!
When I try to go to admin.php
Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /home/u966314614/public_html/lang/en/lang_ad_index.php on line 24
lang_ad_index.php
<?php
//admin index lang file
$lang = array(
'index_bans' => 'Bans',
'index_new_user' => 'Add user',
'index_log' => 'Logs',
'index_mcleanup' => 'Manual cleanup',
'index_user_list' => 'Users list',
'index_tags' => 'Tags',
'index_emoticons' => 'Emoticons',
'index_delacct' => 'Delete account',
'index_stats' => 'Tracker stats',
'index_testip' => 'Test Ip',
'index_user_search' => 'User search',
'index_mysql_overview' => 'Mysql Overview',
'index_mysql_stats' => 'Mysql Stats',
'index_stats_extra' => 'Stats Extra',
'index_categories' => 'Edit categories',
'index_newusers' => 'New users',
'index_resetpassword' => 'Reset password',
'index_rep_system' => 'Reputation system',
'index_rep_settings' => 'Reputation settings',
'index_news' => 'Add/Delete News'
'index_forummanage' 
=> 'Forum manage',-Line 24
'index_moforums' => 'Over Forum manage',
'index_msubforums' => 'Sub Forum manage',


);
?>


When I go to forums.
Fatal error: Call to undefined function get_user_class_color() in /home/u966314614/public_html/forums.php on line 254

Also I tried to acces without staff panel the forum manager,and I got this error
Fatal error: Cannot redeclare get_reputation() (previously declared in /home/u966314614/public_html/include/user_functions.php:23) in /home/u966314614/public_html/include/user_functions.php on line 122

My user_functions is the default one,withot any modifications!

denede

when i write a post, it is written in the middle of the $body window.
when i click preview and after that submit, the page goes to preview again.
anyone has the fix? i know it was fixed on tbdev.net when it was working.

Laur[1]

It's working with you code, thanks cherwonk  :)

cherwonk

 just under the stats area, in the cleanup.php file. Thats where mine is , just above the
Code (php) Select
write_log("Autoclean-------------------- Auto cleanup Complete using $queries queries --------------------");
   }

Laur[1]

Quote from: cherwonk on October 22, 2012, 08:42:42 PM
You are correct there.
Looking at the 09 source that I do have... its in just under the stats area
Code (php) Select
//==  update forum post/topic count
   $forums = sql_query("SELECT t.forumid, count( DISTINCT p.topicid ) AS topics, count( * ) AS posts FROM posts p LEFT JOIN topics t ON t.id = p.topicid LEFT JOIN forums f ON f.id = t.forumid GROUP BY t.forumid");
   while ($forum = mysql_fetch_assoc($forums)) {
   sql_query("update forums set postcount={$forum['posts']}, topiccount={$forum['topics']} where id={$forum['forumid']}");
   }


If your cleanups working properly, check and see if its there. If its not there,take this one.If your clean up isnt working you'll need to find out why. I usually pop a
write_log("Cleanup - did this or that");
in it, if it shows in the log then the codes good to that point, if it doesnt then your problem is before it.

Where to add this?

cherwonk

You are correct there.
Looking at the 09 source that I do have... its in just under the stats area
Code (php) Select
//==  update forum post/topic count
   $forums = sql_query("SELECT t.forumid, count( DISTINCT p.topicid ) AS topics, count( * ) AS posts FROM posts p LEFT JOIN topics t ON t.id = p.topicid LEFT JOIN forums f ON f.id = t.forumid GROUP BY t.forumid");
   while ($forum = mysql_fetch_assoc($forums)) {
   sql_query("update forums set postcount={$forum['posts']}, topiccount={$forum['topics']} where id={$forum['forumid']}");
   }


If your cleanups working properly, check and see if its there. If its not there,take this one.If your clean up isnt working you'll need to find out why. I usually pop a
write_log("Cleanup - did this or that");
in it, if it shows in the log then the codes good to that point, if it doesnt then your problem is before it.

autotron

thats just get call, not an error, but from what I recall post count is done in cleanup...has clean run since posting?

Laur[1]

Here it is:

127.0.0.1 - - [21/Oct/2012:20:45:22 +0300] "GET /forums.php?action=viewforum&forumid=1 HTTP/1.1" 200 2156 "http://localhost/forums.php" "Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0"

autotron

Quote from: Laur[1] on October 21, 2012, 07:27:31 PM
Yes 0 to both

Please check apache error logs, should show where the error is

Laur[1]