Blank Page after install

Started by krazy0mega, October 04, 2011, 03:20:18 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

swizzles

 ;D Glad you got it sorted, I didn't mean it cant be installed on centos, but as CodeMonkey says Centos is a dated and problems arise alot these days, which is why I moved over to deb lenny  ;) a fair time ago.

krazy0mega

I uninstalled memcache and reinstalled it and everything work just fine.
Thanks Anyway.

CodeMonkey

Quote from: krazy0mega on October 04, 2011, 08:16:33 PM
Quote from: CodeMonkey on October 04, 2011, 05:51:44 PM
Try restarting your Apache server or memcache itself /etc/init.d/memcached restart

What else is different between the memcached and the non-memcached version, except the session part. I installed memcache following the link you posted for centos. Memcache seems to be running. I am able to do service memcache restart from putty. But till now unable to install the memcached version. Not sure whats going wrong. Tried the whole day to install this script. Please help, I do not have any clue whats going wrong.  :(

I think you are mistaken i did not post any memcache link for centos, Centos is a problem os all i can suggest is asking your hosting provider to install a different Linux distro and install it all again.
Do NOT PM me directly post in the forums so other users can benefit also :) If you like my posts 1+rep me :)

krazy0mega

yes m8, i have installed it in centos. And memcached is running fine. I tested this with the following snipit:

<?php
$memcache 
= new Memcache;

// Connect
if(!$memcache->connect('localhost'11211)) {
 die(
'Could not connect to server');
}

// Set the cache
$memcache->set("test_hash""It works, mate!"false400);

// Get the cache
if ($ret $memcache->get("test_hash")) {
 echo 
$ret;
}
else {
 die(
'Could not retrieve data from memcached');
}
?>


Why ? Cant it be installed in centos?

swizzles

Ignore me if I am being ignorant , but have you installed this on centos? ::)

krazy0mega

Quote from: CodeMonkey on October 04, 2011, 05:51:44 PM
Try restarting your Apache server or memcache itself /etc/init.d/memcached restart

What else is different between the memcached and the non-memcached version, except the session part. I installed memcache following the link you posted for centos. Memcache seems to be running. I am able to do service memcache restart from putty. But till now unable to install the memcached version. Not sure whats going wrong. Tried the whole day to install this script. Please help, I do not have any clue whats going wrong.  :(

krazy0mega

List of running processes shows that memcached is running and accepting connections at 11211. check the attached screenshot.
Now there are no new errors in apache error log. Problem still persists.

[attachment deleted by admin]

Mindless

#5
Im afraid a phpinfo will not tell you if your memcache server is running, it will tell you the memcache php extension is loaded, the error message you post just tells me instantly your memcache server is not running simple as that otherwise it would connect just fine.

CodeMonkey

Try restarting your Apache server or memcache itself /etc/init.d/memcached restart
Do NOT PM me directly post in the forums so other users can benefit also :) If you like my posts 1+rep me :)

MrRep

double check your memcache install and its running

krazy0mega

Looking into error logs i find:

memcache()connect cannot connect to 127.0.0.1:11211. but memcache is running fine in phpinfo() ??

krazy0mega

After installation is complete I see a blank page when directed to login.php. We error in apache error logs. I have memcached installed.